Get in touch
Back
Degraded

Several services are unavailable at the moment due to Cloudflare CDN Issue

Started 21 Jun at 03:25pm +08, resolved 21 Jun at 04:20pm +08.

COVID-19 Daily Update Server's Status Monitor Media Prima Dailymotion HLS Playlist API Malaysia Textbook Site Looking Glass Official Website Speedtest
Resolved

Issue resolved. According to Cloudflare , this incident has been resolved.
All services are now should be accessible from all users except for geo-restricted services.

Posted 21 Jun at 04:20pm +08.
Updated

Cloudflare is still monitoring the result after a fix has been implemented by Cloudflare. According to our observation and data from Better Uptime , all of our services are now reacheable via Cloudflare CDN from North America / Europe / Asia / Australia. We will continue to provide the latest updates.

Posted 21 Jun at 04:03pm +08.
Created

Several services are unavailable at the moment for all users. During this period, users might be experiencing intermittent access issues to our services. For example, receiving HTTP 4XX and HTTP 5XX response codes. This is because of Cloudflare CDN issues. (https://www.cloudflarestatus.com/)
We will provide updates as soon as possible.

Posted 21 Jun at 03:25pm +08.