Get in touch
Back
Maintenance

Router Gateway Maintenance

Completed 11 Mar at 09:30am +08.

Malaysia Textbook Site Looking Glass Speedtest
Completed

Maintenance completed

Posted 11 Mar at 09:30am +08.
Started

Looking Glass TIMEdotCom MY / EDU Website / Speedtest MY will be unavailable shortly due to router gateway maintenance. This is an urgent maintenance to increase the capacity of the router gateway to provide a better NAT forward performance. All affected services should back online after 30 minutes.

Posted 11 Mar at 08:46am +08.