Get in touch
Back
Maintenance

Server maintenance

Completed 27 Feb at 12:39pm +08.

Looking Glass Official Website Speedtest
Completed

Maintenance done. All services should be back to online in 2 minutes.

Posted 27 Feb at 12:39pm +08.
Started

Server maintenance. It should take no longer than 10 minutes.

Posted 27 Feb at 12:36pm +08.