Get in touch
Back
Maintenance

System Migration

Completed 22 Sep at 12:00am GMT+8.

Malaysia Textbook Site Looking Glass Speedtest
Completed

Maintenance completed

Posted 22 Sep at 12:00am GMT+8.
Started

All services involving MY_PJ Node will be undergoing system migration and maintenance. Service may be unavailable or intermittent during this period. Currently, there is no estimated time of completion for the migration. We will keep you updated.

Posted 22 Aug at 12:00am GMT+8.